[RESOLVED] Singapore DC : Network Interruption Monday 13th May 2024 16:28:07


We're currently experiencing degraded network performance in our Singapore data center, affecting some clients. Our Network Engineers are actively investigating the root cause of this interruption. Rest assured, we're working diligently to resolve the issue. We'll keep you updated with any new information as it becomes available. Thank you for your patience and cooperation.

UPDATE 04:50 PM ET: The issue has been resolved, and services should be operating normally. However, we will continue to closely monitor the network to ensure stability. We appreciate your patience and understanding throughout this process. If you experience any lingering problems, please do not hesitate to contact our customer support. We are here to assist you.