[COMPLETED] SG DataCenter : Scheduled Network Maintenance Monday 13th May 2024 12:00:00


Start: 14 May 12:00 AM SGT (13 May 12:00PM EDT)

End: 14 May 04:00AM SGT (13 May 04:00PM EDT)

Description: Our System Operations team will be performing scheduled maintenance on the Singaporean Datacenter. Users may experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 12:00PM EDT: The maintenance has started.

UPDATE 03:21 PM EDT: The maintenance has been completed.