[COMPLETED] Emergency Maintenance :: az1-ss30 Thursday 2nd May 2024 01:02:07


Start Date: May 2, 2024

Time: 3 AM ET

Services Affected: az1-ss30

Description: Our System Operations team will conduct Emergency Maintenance on this server. During this time, users may experience a brief service interruption. We'll keep you updated on any developments in this thread.

UPDATE 3:00 AM: The maintenance has started.

UPDATE: 3:15 AM: The maintenance has been completed.