[COMPLETED] MI DataCenter : Scheduled Network Maintenance Wednesday 1st May 2024 19:52:21


Start: May 2, 2024, at 12:00 AM EDT

End: May 2, 2024, at 03:00 AM EDT

Description: Our System Operations team will conduct scheduled maintenance on the Michigan Datacenter. During this period, users may experience a brief service interruption as we perform routine maintenance tasks. We'll provide all updates related to this maintenance in this thread.

UPDATE 12:00 AM: The maintenance has started.

UPDATE: 3:00 AM: The maintenance was completed.