[COMPLETED] Live Chat :: Scheduled Maintenance Tuesday 30th April 2024 07:44:16


Date: Sunday, May 05, 2024

Time: 10:00 PM - 12:00 AM EDT

Services Affected: Live Chat

Description: Our Live Chat Software requires mandatory maintenance to ensure a smooth and stable service going forward. During the scheduled maintenance, there may be brief interruptions to our Live Chat service. Please utilize our ticketing or phone systems for assistance during this period.

UPDATE 10:00 PM EDT: The scheduled maintenance has started.

UPDATE 12:00 AM EDT: The maintenance has been completed.