[RESOLVED] Multiple SG servers :: Service Interruption Sunday 21st April 2024 13:09:46


Multiple servers in our Singapore Data Center are presently encountering a service interruption. This may lead to service degradation for users hosted on these servers. Our System Operations team is actively investigating the root cause of these interruptions. We will keep you updated as soon as more details become available. Thank you for your patience and understanding.

UPDATE 2:30 EDT: The issue has been successfully resolved. It was caused by a network problem originating from Telstra when attempting to connect to the A2 Hosting network. However, services remained accessible from other Internet Service Providers.