[COMPLETED] az1-ts2 :: Emergency Maintenance Saturday 20th April 2024 22:12:52


Start Date: Saturday, April 20th, 2024 EDT

Time: 10:15 PM EDT

Services Affected: az1-ts2

Description: Our System Operations team will be conducting emergency maintenance on the servers. Users may experience service interruptions while essential maintenance tasks are performed. We appreciate your understanding and patience during this period.

UPDATE 10:18 PM EDT: Maintenance completed successfully.