[RESOLVED]Arizona Data Center :: Scheduled Maintenance Thursday 18th April 2024 21:00:00


Start Date: Thursday, April 18th, 2024 EDT

End Date: Friday, April 19th, 2024 EDT

Time: 9:00 PM - 9:00 AM EDT (6:00PM - 6:00AM MST)

Description: Our Engineering team is scheduled to perform routine maintenance at the Arizona data center. We anticipate no interruptions to your service during this time.

Please refer to this thread for all updates related to the maintenance.

UPDATE 9:00 PM EDT: The maintenance has started.

UPDATE 9:00 AM EDT: The maintenance was completed.