[RESOLVED] Michigan VPS Servers :: Network Interruption Friday 12th April 2024 07:37:47


We detected intermittent performance issues impacting some VPS servers in our Michigan data center. Our Network Engineers are actively investigating to identify the root cause of this problem, and we will keep you informed with updates as we gather more information.

UPDATE 7:55 AM EDT: Our Engineering team has resolved the issue. Services are online and available at this time.