[COMPLETED] Arizona DataCenter :: Scheduled Network Maintenance Thursday 4th April 2024 04:00:00


Beginning: April 04 ( Thursday ), 2024 at 04:00 AM EDT 

Ending: April 04 ( Thursday ), 2024 at 07:00 AM EDT 

Description: Our System Operations team will be performing scheduled maintenance on the Arizona Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 4:00 AM EDT: Our System Operations team started this maintenance. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE 7:00 AM EDT: The maintenance has been completed.