[COMPLETED] NL DataCenter :: Scheduled Network Maintenance Tuesday 2nd April 2024 18:00:00


Start Time:  April 02 (Tuesday), 2024 at 6:00 PM EDT

Description: Our System Operations team will be performing scheduled maintenance on the Netherlands Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 6:00 PM EDT: Our System Operations team started this maintenance. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE 9:00 PM EDT: The maintenance has been completed.