[COMPLETED] sg1-vz7517-vm15 :: Emergency maintenance Friday 29th March 2024 01:45:34


Our System Operations team will be performing emergency maintenance on the node sg1-vz7517-vm15. Users hosted on this node may experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 02:20 AM EDT: The maintenance is now completed.