[RESOLVED]TurboHub :: Scheduled Maintenance Monday 25th March 2024 03:10:33


Start Date: March 27th, 2024, Wednesday

Time: 06:00 AM EDT - 06:30 AM EDT

Services Affected: TurboHub control panel

Description: Our System Operations team will be performing scheduled maintenance on the TurboHub control panel. Users will experience a brief service interruption of this interface while the maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE: The maintenance was completed without issue.