[RESOLVED] mi3-sr20 :: Service Interruption Wednesday 20th March 2024 20:28:38


mi3-sr20 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 8:30 PM EDT: Issues on mi3-sr20 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.