[RESOLVED] Support Helpdesk :: Service Interruption Friday 15th March 2024 20:13:12


We are experiencing an issue with customers submitting tickets. We are available on chat and phone support. Appreciate your patience as we are working on the resolution, We will provide updates on this page as we have more information in this regard. We appreciate your patience and understanding in the meanwhile.

UPDATE 8:30PM EST: Issues with the support ticketing system have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.