[COMPLETED] mi3-ss18 :: Emergency Maintenance Friday 15th March 2024 12:21:07


Our System Operations team will be performing emergency maintenance on mi3-ss18. Users hosted on this server may experience service degradation as a result. We will provide updates as more details are made available.

Update 02:45 PM EDT: The maintenance is completed, all services are back online at this time.