[RESOLVED]mi3-ss19 :: Service Interruption Friday 15th March 2024 10:10:30


mi3-ss19.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this issue. We will provide updates as more details are made available.

UPDATE 11:00AM ET: Our System Operations team has identified the root cause of this issue and is working to resolve it as soon as possible. Further updates will be provided.

UPDATE 11:50AM ET: Our System Operations team is still working to bring all services online. We appreciate your patience and understanding. We will provide further updates.

UPDATE 12:15AM ET: Our System Operations team has restored services at this time. All services are online and available. Please reach out to our Support team if issues are still present.