[RESOLVED]Michigan servers :: Network Interruption Friday 15th March 2024 05:10:18


We detected intermittent performance issues impacting some clients on our Michigan servers. Our Network Engineers are actively investigating to identify the root cause of this problem, and we will keep you informed with updates as we gather more information.

UPDATE 06:40 AM EDT: Our engineering team is actively addressing a network issue. While some users on Mi servers may experience intermittent interruptions, we appreciate your patience. Updates will be provided in this thread.

UPDATE 9:45AM EDT: Our Engineering team has resolved the issue. Services are online and available at this time.