[RESOLVED] mi3-ts105 :: Service Interruption Friday 8th March 2024 15:28:04


Server mi3-ts105 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 3:43 PM EST: Our System Operations team resolved this matter and all services are back online at this time.