[RESOLVED] mi3-ts103 :: Service Interruption Tuesday 5th March 2024 20:32:10


mi3-ts103 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 7:15PM EST: Issues on mi3-ts103 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.