[COMPELTED] Michigan DataCenter :: Scheduled Network Maintenance Thursday 7th March 2024 00:00:00


Date: March 7th, 2024 (Thursday)

Start Time (EST): 12:00 AM

End Time (EST): 6:00 AM

Description: Our System Operations team will be performing scheduled maintenance on the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 12:00 AM: The maintenance has started.

UPDATE 03:53 AM EST: The maintenance is completed.