[RESOLVED] mi3-sr11 :: Service Interruption Saturday 2nd March 2024 13:22:54


mi3-sr11.supercp.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 1:45 PM EST: Our System Operations team was able to resolve the issue. Services are available at this time.