[RESOLVED]mi3-wts7 :: Service interruption Tuesday 5th June 2018 13:39:03


We are aware of an issue that was impacting users ability to login to Plesk. Our system operations team is currently working on the issue which will require some services to be restarted to correct. We will post updates as they become available.

UPDATE 17::53 Eastern :: We are happy to announce services are back online and functional.