[RESOLVED] External network issue :: AZ servers Wednesday 14th February 2024 05:42:31


We are getting reports of connectivity issues affecting a significant subset of customers on our Shared/Reseller/VPS/Dedicated platforms located in Arizona.

It has been found that there is a problem with the specific communication provider - TATA Communications. Some customers routed through this network may experience a timeout while trying to access the website or services. We will keep this thread updated as we get more information. We appreciate your patience in the meantime.

UPDATE 10:20 AM EST: The issue with TATA Communications is resolved. Please, contact our support if you experience any difficulties. We thank you for your understanding and patience.