Netherlands DC :: Network Interruption Wednesday 24th January 2024 13:12:26


We are aware of degraded performance faced by some clients hosted in our Netherlands Datacenter. Our Network Engineers are actively investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 2:15PM ET: Our Network Engineers have identified an issue and are coordinating with upstream providers to correct it. Further updates will be provided as they become available.

UPDATE 4:35PM ET: Our Network Engineers have made significant progress in addressing the root cause of the performance degradation. They are actively implementing corrective measures to restore normalcy to the affected services. Further updates will be provided as the situation develops.

UPDATE 5:35 PM ET: The issue has been resolved, and services should be operating normally. However, we will continue to closely monitor the network to ensure stability. We appreciate your patience and understanding throughout this process. If you experience any lingering problems, please do not hesitate to contact our customer support. We are here to assist you.

UPDATE 25 January 2024 10:25AM ET: We are aware of the degraded performance experienced in our Netherlands DC at this time. Our Network Engineers are actively coordinating with our upstream providers to correct this issue. We will provide further updates as we receive them.

UPDATE 26 January 2024 1:00 PM ET: We remain vigilant in monitoring the network to uphold its stability. Should you encounter any persisting issues with the service, please don't hesitate to reach out to us.