[RESOLVED] mi3-sr26 :: Service Interruption Wednesday 24th January 2024 07:20:43


mi3-sr26 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 7:32AM: The service is online and available once again. We will continue to monitor the service for any issues.