[COMPLETED] Netherlands DataCenter :: Scheduled Network Maintenance Tuesday 23rd January 2024 23:59:20


Start Date: January 24, Wednesday 06:00 PM EST

Description: Our System Operations team will be performing scheduled maintenance on the NetherlandsĀ Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 6:00 PM EST: Our System Operations team started this maintenance. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE 07:00 PM EST: The maintenance has been completed.