[RESOLVED]Issues with PayPal payments Monday 4th June 2018 01:35:53


We are currently experiencing issues with accepting payments via PayPal. This issue is being looked into and we will post updates as soon as we'll have more information available.

UPDATE: 7:30 AM EDT: The issue has been fixed and PayPal payments should work now. Please let us know if you run into any more issues.