[RESOLVED] Singapore DC :: Network Interruption Sunday 14th January 2024 08:00:00


We detected a performance issue impacting some clients on our Singapore servers. Our Network Engineers are actively investigating to identify the root cause of this problem, and we will keep you informed with updates as we gather more information.

UPDATE 3:10 AM EST, January 15th: We still see this issue on some of our Singapore servers. Our Network Engineers are aware of this situation and are working on it. We will provide updates as more details are made available.

UPDATE 5:50 AM EST, January 15th: The issue is now solved and the services are currently back to normal. If you encounter any problems, please contact our support team.