[RESOLVED] sg1 servers/network :: Service Interruption Wednesday 10th January 2024 23:33:32


The Singapore sg1 network is currently experiencing a service interruption. Users hosted on these servers will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE: 01:40 AM ET: The Singapore network is again responsive. If you are still encountering any issues, please don't hesitate to let us know.