[COMPLETED] Singapore Data Center :: Network Maintenance Thursday 11th January 2024 12:00:00


Start Date: Thursday, January 11th, 2024 EDT

End Date: Thursday, January 11th, 2024 EDT

Time: 12:00 PM - 4:00 PM EDT

Description: Engineering team will be performing scheduled maintenance in the Singapore data center. Users may experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE: Maintenance has been Completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.