[RESOLVED] Sectigo SSL Certificates :: Degraded Performance Friday 15th December 2023 01:19:40


Sectigo is currently experiencing degraded performance with its issuing platforms. Users will experience delays with free SSL certificates being issued or renewed as a result.

You can view Sectigo's status page here:

https://sectigo.status.io/ 

We will provide further updates as they're made available.

UPDATE 02:16 AM EST: Sectigo reports the problem as resolved.

https://sectigo.status.io/pages/incident/5938a0dbef3e6af26b001921/657be564ffc7610534a1a8be