[COMPLETED] Scheduled Maintenance:: mi3-ls4.a2hosting.com Friday 8th December 2023 02:00:00


Time: Dec 8, Friday 02:00 AM EST 

Description: Our System Operations team will be performing scheduled maintenance on the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 2:05 AM EST: The maintenance has begun. Updates will be provided when they become available.

UPDATE 2:12 AM EST: The maintenance has been completed.