[COMPLETED] Michigan DataCenter :: Scheduled Network Maintenance Wednesday 6th December 2023 00:00:00


Start Time: December 6 ( Wednesday ), 2023 at 12:00 AM EST 

End Time: December 6 ( Wednesday ), 2023 at 03:00 AM EST 

Description: Our System Operations team will be performing scheduled maintenance on the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 3:00 AM EST: The maintenance has been completed.