[COMPLETED] Netherlands DataCenter :: Scheduled Network Maintenance Tuesday 5th December 2023 18:00:00


Start Time: December 5 (Tuesday), 2023 at 06:00 PM EST 

Start Time: December 5 (Tuesday), 2023 at 09:00 PM EST 

Description: Our System Operations team will be performing scheduled maintenance on the Netherlands Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 6:00 PM EST: Our System Operations team started this maintenance. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE 7:39 AM EST: The maintenance has been completed.