[COMPLETED] Arizona DataCenter :: Scheduled Network Maintenance Tuesday 31st October 2023 03:00:00


Start Time (EDT): 3:00AM October 31st, 2023

End Time (EDT): 7:00AM October 31st, 2023

Start Time (Local Server Time): 12:00AM

End Time (Local Server Time): 4:00AM

Description: Our System Operations team will be performing scheduled maintenance on the Arizona Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 3:10 AM EDT: Our System Operations team started this maintenance. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE 07:00 AM EDT: The maintenance has been completed.