[COMPLETED] Singapore DataCenter :: Scheduled Network Maintenance Thursday 26th October 2023 12:00:00


Start Time (EST): 12:00PM October 26th, 2023

End Time (EST): 3:00PM October 26th, 2023

Start Time (Local Server Time): 12:00AM, October 27th, 2023

End Time (Local Server Time): 3:00AM, October 27th, 2023

Description: Our System Operations team will be performing scheduled maintenance on the Singapore Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 12:00 PM EDT: Our System Operations team started this maintenance. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE 1:00 PM EDT: The scheduled maintenance has now been completed. Please reach out to our Support Team should you encounter any issues.