[COMPLETED] Michigan DataCenter :: Scheduled Network Maintenance Wednesday 25th October 2023 20:40:27


Start Time (EDT): 12:00AM, October 26th, 2023

End Time (EDT): 4:00AM, October 26th, 2023

Description: Our System Operations team will be performing scheduled maintenance on the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 12:00 AM EDT: Our System Operations team will start this maintenance shortly. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE 12:20 AM EDT: Our System Operations team started this maintenance. We appreciate your patience and understanding and further updates will be provided as they become available.

UPDATE 1:10 AM EDT: The scheduled maintenance has now been completed. Please reach out to our Support Team should you encounter any issues.