[COMPLETED] Scheduled Maintenance :: sgssr3 Tuesday 17th October 2023 02:51:03


Start Date: Wednesday, October 18th, 2023 4:00PM EDT (Server Time: Thursday, October 19th, 2023 4:00AM SGT) 

End Date: Wednesday, October 18th, 2023 5:00PM EDT (Server Time: Thursday, October 19th, 2023 5:00AM SGT)

Services Affected: sgssr3.supercp.com

Our System Operations team will be performing the maintenance of the server sgssr3.supercp.com. Users hosted on this server may experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 4:45PM EDT: Maintenance has been completed. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.