[COMPLETED] Michigan Data Center :: Network Maintenance Thursday 5th October 2023 23:57:46


Start Date: Friday, October 6th, 2023 EDT

End Date: Friday, October 6th, 2023 EDT

Time: 12:00 AM - 2:00 AM EDT

Description: Engineering team will be performing scheduled maintenance in the Michigan data center. Users may experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE 02:00 AM: The maintenance is completed.