[RESOLVED] Service Interruption :: Domain Registration Wednesday 4th October 2023 23:14:41


Our Domain Registration system is currently experiencing a service interruption. New domain orders may not go through immediately. Our Engineers are working on this. We will provide updates as more details are made available. 

UPDATE: The issue is addressed and the registration system is now working as expected. Please reach out to our Support team should you encounter any additional issues.