[COMPLETED] Scheduled Maintenance :: mi3-sr14 Saturday 23rd September 2023 01:00:00


Start Time: September 23nd, Saturday 01:00AM EDT

End Time: September 23nd, Saturday 05:00AM EDT

Our System Operations team will be performing the maintenance of the server mi3-sr14.supercp.com. Users hosted on this server may experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 1:00 AM EDT: The scheduled maintenance has started. Updates will be provided as they become available.

UPDATE 1:15 AM EDT: The maintenance has been completed at this time and the server is back online.