[RESOLVED]mi3-tr102 :: Service Interruption Friday 15th September 2023 10:37:51


mi3-tr102.a2hosting.com is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 11:00 AM EDT: Our System Operations team were able to resolve the issue. Services are available at this time.