[RESOLVED] Live Chat :: Service Interruption Tuesday 5th September 2023 18:13:30


Our Live Chat application is currently facing issues. Clients contacting us via Live Chat may experience service degradation and disconnections as a result. We are investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 9:29 PM ET: The Live Chat service should be restored at this time.