[RESOLVED] src8 :: Service Interruption Thursday 31st August 2023 05:28:08


src8 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available. 

UPDATE 07:00 AM EDT: Our Engineers were able to fix the problem, The server is up and running again.