[Resolved] Our Website :: Service Interruption Monday 28th August 2023 05:06:27


Our website is currently experiencing a service interruption. Users may experience features missing or not working normally. Our development team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 05:35 AM EDT: Issues with our website have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.

UPDATE 06:25 AM EDT: Some users may experience a time-out error while opening the Knowledgebase page. Our engineers are working on this problem. 

UPDATE 06:55 AM EDT: The Knowledgebase is accessible again.