[RESOLVED] mi3-lr4 :: Service Interruption Tuesday 22nd August 2023 18:00:40


mi3-lr4 is currently experiencing a service interruption. Users hosted on this server will experience service degradation as a result. Our System Operations team is investigating the root cause of this interruption. We will provide updates as more details are made available.

UPDATE 8:00PM EDT: Issues on mi3-lr3 have been resolved. If you continue to experience any issues with the service, please do not hesitate to contact our live support for assistance.