[Completed] Scheduled Maintenance :: mi3-ls6 Saturday 19th August 2023 03:13:58


Start Date: Monday, August 21, 2023 ET 

End Date: Monday, August 21, 2023 ET  

Time: 02:00 AM Eastern Time.

Our System Operations team will be performing the maintenance of the server mi3-ls6.a2hosting.com. Users hosted on this server may experience service degradation as a result. We will provide updates as more details are made available.

UPDATE 02:36 AM EDT: The maintenance is completed.