[Completed] Michigan Network Maintenance Thursday 27th July 2023 00:53:39


Start Date: Thursday, July 27, 2023 EDT

End Date: Thursday, July 27, 2023 EDT

Time: 12:00 AM - 6:00 AM EDT

Description: Our System Operations team will be performing scheduled maintenance in the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE: 01:00 AM EDT: Users may experience service interruptions. Our Engineers are working on the problem right now. We appreciate your understanding and patience. We are going to keep this post updated as more news is available.

UPDATE: 02:15 AM EDT: Some users hosted on Michigan Shared/Reseller/Turbo servers may experience accessibility issues. Our Engineering team is actively working on addressing this problem. Further updates will be provided.

UPDATE: 02:50 AM EDT: Our Engineers have corrected the Michigan DC connectivity issue. The scheduled maintenance has now been completed. Please reach out to our Support Team should you encounter any issues.