[COMPLETED] Scheduled Michigan Network Maintenance Thursday 20th July 2023 00:57:35


Start Date: Thursday, July 20th, 2023 

End Date: Thursday, July 20th, 2023  

Time: 01:00 AM - 06:00 AM EST

Services Affected: Michigan Network

Description: Our System Operations team will be performing scheduled maintenance on the Michigan Datacenter. Users will experience a brief service interruption while the routine scheduled maintenance is performed. We will post all updates associated with this maintenance in this thread.

UPDATE: 06:00 AM EST: The scheduled maintenance has been completed.